王筝的博客
ruby学习

http://stackoverflow.com/questions/5286117/incompatible-character-encodings-ascii-8bit-and-utf-8

http://stackoverflow.com/questions/22932282/gemloaderror-specified-mysql2-for-database-adapter-but-the-gem-is-not-loade

这个是因为在Gemfile和database.yml里写的都是mysql,

应该是mysql2.

修改之后报出新错误:“

Gem::LoadError Specified ‘mysql2′ for database adapter, but the gem is not loaded. Add `gem ‘mysql2’` to your Gemfile

配置一下mysql2 的版本

If you have this error when upgrading to rails 4.2.4 (also with rails 4.1.5) try using this version of mysql2:

gem 'mysql2', '~> 0.3.18'

Leave a Reply